Errors with IntelliJ IDEA Maven Plugins


Hi. I'm having an issue with getting an ESLint: Parsing Error in a few js files related to api calls. I think this issue might relate to a bigger problem that was caused about a year ago that ended up having no solution. Members of my team tried to help with the problem, but we never came to a conclusion on what was causing the problem or how to solve it. The problem seems to be related to my maven project plugins. I've tried reimporting and reloading all the maven projects, restarting intellij, generating sources and updating folder for all maven projects, and I believe the last suggestion was to possibly reinstall IntelliJ. I was told to hold off on doing that though since that would take awhile and the errors weren't causing any issues at the time, but I believe the ESLint errors might be related to these maven issues. I also have "Use plugin registry" selected within the maven settings and tried going through the "Repair IDE" steps. Nothing seems to get rid of the maven plugin errors. I'll attach a screenshot of the errors as well.


I do not see how ESLint errors might be related to these Maven errors.

To fix these Maven errors, please make sure the plugin exists in the Maven local repository, which is specified in IDE Maven settings (Settings (Preferences on macOS) | Build, Execution, Deployment | Build Tools | Maven | Local repository).

Try to execute any Maven goal(from command line or from IDE Maven tool window) provided by these plugins - does it complete successfully?


Andrey Dernov It appears that I'm able to do a maven clean and install. It doesn't appear that this issue is causing any noticeable issues or any issues that are preventing me from running tests or building my project successfully. Even with the ESLint errors I'm experiencing, those js files experiencing the error still work without any problems when testing them. As far as the ESLint errors go, it appears that I have the proper setup within my eslint file that matches up with the rest of my team that's why I thought maybe the maven issues I'm having could be causing some kind of weird issues that are triggering that error.


If you can provide the IDE log (Help | Collect Logs... action) I will check if there are any suspicious errors that may cause Maven highlighting issues.

For uploading you can use or any file sharing service. Thanks.


Andrey Dernov Upload id: 2023_01_24_iWz1NL3hPm8W6XYKELHBWs (file:


There are some exceptions in log that were fixed in latest IDE versions. Please try latest version from

Also try to purge the Maven local repository and re-download dependencies:


Please sign in to leave a comment.