Hub can't add YouTrack service to new project

I'm having an issue when I try to add the YouTrack service to a newly created project in Hub.

On the project page, I click on the "+" symbol and then on "Issue Tracker".
In the bottom right corner of the window the message "TypeError: Failed to fetch" pops up.

If I follow the same procedure but click on the UpSource link, everything works fine.

Hub and YouTrack run on two different machines.
Version of Hub: 2020.1.12375
Version of YouTrack: 2017.4 (build 39533)

If I open the setting menu of YouTrack, go to Hub Integration and run the diagnostics, no error is shown.

Any idea, where this issue could come from?
Kind regards, Enpa


Official comment


I'm Sergey from the Youtrack team.

Thank you for the message. I'm happy to help you.

Please try adding your Hub URL to the Allowed Origins in Youtrack settings → Global settings.


Alternatively, upgrading your Youtrack to the latest version should help as well, as this should be handled automatically. 

If any questions appear, please let me know. 

Hi Sergey

Thank you for your answer.

I tried to add the allowed origin, but it didn't help.
I also ticked the box "Allow all origins": same issue.

I restarted both services (Hub and YouTrack), I still can't add the service.

Our maintenance license is expired and at the moment, because of the current situation, there is a stop on investments.
I can ask for a license renewal if you are sure that this will fix the issue.

Thank you for your help!

Kind regards, Enpa


Thanks for your reply. 

To start off, please share the following details:

  • Hub logs
  • a HAR file recorded when reproducing the issue
  • the screenshot of the Allow origin settings in Youtrack 

As this data may be sensitive to post in public, please fill in a direct request at

Once we review these details, we'll get back to you with further information. 


I uploaded the requested files. Thank you :-)


Great, let's continue in the ticket then. I've already sent you a reply there and am looking forward to hearing back. 


Please sign in to leave a comment.