Hub OAuth Module behind corporate proxy

Hi,

I'm trying to configure my Hub instance to connect to my company's Gitlab instance and it seems Hub is ignoring the http proxy when it tries to authenticate my user.

Proxy settings are set in hub.jvmoptions

-Dhttp.proxyHost=xxx
-Dhttp.proxyPort=xxx
-Dhttps.proxyHost=xxx
-Dhttps.proxyPort=xxx

When I try to login via the Gitlab auth module, Hub throws a connection refused error.

Caused by: org.apache.http.conn.HttpHostConnectException: Connect to xxxxx:443 [xxxxx/xxx.xxx.xxx.xxx] failed: Connection refused (Connection refused)

I have confirmed access to Gitlab works when the request goes through the proxy.

I even tried changing the proxy in hub.jvmoptions to a junk value and Hub still ignored it.

Am I missing something?

Thanks

0
2 comments
Official comment

Hello!

> I'm trying to configure my Hub instance to connect to my company's Gitlab instance

What flow exactly are you trying to set up? How is Hub supposed to connect to Gitlab? Are you setting up a Gitlab Auth module? Please provide more details.

 

> When I try to login via the Gitlab auth module, Hub throws a connection refused error.

Do you see this on the login form? Could you please share a screenshot?

 

>  it seems Hub is ignoring the http proxy when it tries to authenticate my user.

Do you see this in the logs? I'd recommend you create a support request to us and provide the full Hub /log and /conf folders along with a screenshot with the error so that we could investigate this case. Here's the link to the support request form: https://hub-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=66692

 

Thank you.

Hi,

I was setting up the Gitlab Auth Module.

I managed to convince my networking team to allow a direct connection without the proxy to our Gitlab server so I'm all set now.

 

Thanks

0

Please sign in to leave a comment.