TeamCity build artifact widget showing "No connection to service"

This is only a problem for guest users - I can't work out how to allow unauthenticated (guest) users to see a TeamCity build artifact widget on my default guest dashboard.

More background - running YouTrack, TeamCity and Hub (all latest builds) without any problems. For nomal users dashboards are all working properly. However, I have a "guest" dashboard set up so that people without credentials to Hub can view current build/issue status.

I have set up a dashboard and shared it with guest user. YouTrack widgets all work fine - guest users can view these. But TeamCity widgets do not work.

When a guest user views the dashboard they see a placeholder for the TeamCity build artifact widget and an error message - "This widget cannot connect to the TeamCity service".

Note: I *have* configured CORS on the TeamCity server;

rest.cors.optionsRequest.allowUnauthorized is set to true, and

rest.cors.origins is set to the URL of the HUB server.

No proxies are involved.

Are there any other settings I should be looking at?

1 comment
Comment actions Permalink

Hello,

Please make sure that TeamCity guest account is enabled: https://confluence.jetbrains.com/display/TCD10/Guest+User.

Thank you!

0

Please sign in to leave a comment.