Hub and YouTrack error

Completed

Hello,

Today I've tried to setup Jetbrains Hub and YouTrack to test it out. But when I tried to connect YouTrack with my installed Hub it says this on the installation site: "Cannot use Hub: HTTP 400 Bad Reques". When I look in my Hub and YouTrack console it throwed this errors:

Hub: https://hastebin.com/cupabulixe.sql

YouTrack: https://hastebin.com/vixolileke.sql

I'm using Ubuntu 14.04 as OS, Hub version 2017.3.6757, YouTrack version 2017.3.35488 and I've set the base urls to localhost

11 comments
Comment actions Permalink

Hello!

Please change your base URL so that it doesn't contain the .04 part. It looks like it is the reason of the issue.

Let us know the results. Thanks!

0
Comment actions Permalink

Here are some hints as to which base URL names are valid:

`Such a name consists of a sequence of domain labels separated by ".",
each domain label starting and ending with an alphanumeric character
and possibly also containing "-" characters. The rightmost domain
label of a fully qualified domain name in DNS may be followed by a
single "." and should be if it is necessary to distinguish between
the complete domain name and some local domain.`

https://tools.ietf.org/html/rfc3986#page-21

0
Comment actions Permalink

I've changed the url to localhost at the set-up screen from Hub and YouTrack. I've also searched in all files for ubuntu14.04 and changed it to localhost but still it doesn't work

0
Comment actions Permalink

For some reason changing the permissions of the conf folder fixes the problem for me. Thanks for the help

0
Comment actions Permalink

Thanks for the update! We're glad the issue is resolved.

0
Comment actions Permalink

Actually its not fixed :(. I've set YouTrack up now but when it starts it throws a new error:

Hub: https://hastebin.com/zeremajido.nginx
YouTrack: https://hastebin.com/botodagema.bash

And the config files from YouTrack all changed back from localhost to ubuntu14.04 as well as the conf folder is again not writable without chmodding the folder.

0
Comment actions Permalink

It looks like one of the known issues in Hub which is already fixed, but the fix is not yet released.

Old redirect URIs are stuck in the database, and without our fix only a clean installation can help. So we recommend to re-install YouTrack afresh, creating a new clean database during the installation process.

Please let us know the results. Thanks.

0
Comment actions Permalink

I'm using an external Hub that I host locally on the same computer as I host YouTrack. Do I have to reinstall both?

0
Comment actions Permalink

Yes, please reinstall both. Thanks!

0
Comment actions Permalink

Removed all old folders, unziped Hub and YouTrack again, started each one and stopped it. Changed every ubuntu14.04 that greb found to localhost and setting it up again still didn't fixed it. It comes through the installation process without a problem but when starting up it still throws that 400 bad request error.

(This one: [YouTrack Error] [2017-08-28 17:33:43,882] ERROR - es.impl.HubConfiguratorService - Cannot update Hub properties: HTTP 400 Bad Request. Details: Field Service::redirectUris is not a valid URIs set )

0
Comment actions Permalink

It looks like ubuntu14.04 (or some other incorrect host name) is still returned by command `hostname` on a server, otherwise it is not clear how bad redirect URIs might have been constructed. By the way, list of incorrect URIs should be in logs (logs/internal/services/bundleProcess/debug.log or logs/hub/all.logs)

 

0

Please sign in to leave a comment.