OAuth Button Image - Cant Change Default

The page says to "Upload a JPG, GIF, or PNG file. The image is resized to 48 x 48 pixels automatically"

Clicking the image does not prompt an upload screen. I did not see this image in the file system.

 

What am I missing here?

 

JetBrains Hub 2017.2
Build 2017.2.5942 [07-06-2017 16:35]
5 comments
Comment actions Permalink
Official comment

Hello,

Thank you for reporting a bug. We'll work on delivering the fix.

Comment actions Permalink

Hello, I'm sorry for the delay in reponse.

Which browser are you using? Have you tried another one or have you tried to use Incognito mode?

What exactly do you see when you hover over the image with your mouse?

Additionally, please record a HAR file on the opening of the Auth Module setting page. Instructions are here, p.3: https://youtrack-support.jetbrains.com/hc/en-us/articles/206546369-When-we-ask-you-to-provide-additional-details-logs-database-HAR-etc-

Thank you! 

0
Comment actions Permalink

Also seeing this issue in both Chrome and Firefox inside and outside of the incognito mode(s).

Looking at developer tools I'm not seeing any console js errors so not overly sure why this isn't working.

I'm unable to provide a HAR as this contains a lot of session related information, however it's very easy to reproduce. 

Auth Modules
New Module
oAuth 2.0 
Enter a random name and server url & click create
Click the button image

Expected:- file picker opens
Actual:- nothing happens

If this works for anyone please say so we know if this is working for some and not others.

Would be nice to have this working as the auth icons on the login aren't exactly prominent and without a recognisable icon we are going to end up with "how do i login" questions ...  

0
Comment actions Permalink

Has this been resolved in 2018.1, I did not see it in the release notes.

0
Comment actions Permalink

Hello,

Yes, it has been resolved. Please refer to this issue: https://youtrack.jetbrains.com/issue/JPS-7342.

Thank you. 

0

Please sign in to leave a comment.