Webstorm how to change default Mocha IntellijReporter

Answered

I want to use Mochawesome Reporter instead of Mocha IntellijReporter.

When I run my script from Webstorm I see both the reporters are added and mocha awesome reports are not created.

 

--reporter mochawesome --ui tdd --reporter /Applications/WebStorm.app/Contents/plugins/NodeJS/js/mocha-intellij/lib/mochaIntellijReporter.js

4 comments
Comment actions Permalink
Official comment

Hello, I'm sorry for the delay.

I believe that you've already got the answer here: https://stackoverflow.com/questions/44575915/webstorm-not-able-to-change-default-mocha-reporter/44584954?noredirect=1#comment76256282_44584954

I'm posting this link in case someone else wants to know the answer.

Comment actions Permalink

Hi,

 

With this solution we can't use Webstorm's awesome test features... Wouldn't it be reasonable simply not to add jetbrain's reporter if "--reporter" is in the field "Extra Mocha options" ?

 

Thanks,

 

BR

2
Comment actions Permalink

What should I do if I run mocha in command line and it works great but if I run it through Webstorm I have an error "No executable!" on each test? I'm using:

mocha-typescript
ts-test-decorators

As I understood the problem is in Webstorm reporter and I don't know how to fix it

0
Comment actions Permalink

What does your run configuration look like, what mocha version do you use? The mocha-typescript package seems to be outdated, the https://github.com/testdeck/testdeck/tree/master/packages/@testdeck/mocha has to be used instead...

Anyway, I'd suggest trying the instructions from https://www.npmjs.com/package/mocha-typescript#ides - do they work for you?

0

Please sign in to leave a comment.