Set indentation for css files

Answered

When editing a .css file, the default indent is 4 spaces - I need it to be 2. (A single tab should equal 2 spaces as well...)

I've done every Google search I can think of but cannot figure out how to make this happen.

Please help!

2 comments
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello,

Please check File | Settings (or PhpStorm | Preferences) | Editor | Code Style | CSS > Tabs and Indents.

Set the tab size and indents to 2 spaces and it should be done.

0
Comment actions Permalink

Thanks.

I was doing that, repeatedly, but it had no effect.  Until I closed and re-opened PhpStorm - that did it.

Don't know if restarting is supposed to be required, but hopefully this will help someone else if they run into the same issue and are searching for an answer like I was....

Regardless, thanks again!

1

Please sign in to leave a comment.